import Foundation
let pattern = #"^([^,]+),"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
1,,000.23
0,9
0.0
,55,55555,5555
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1."#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)