// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([^,]+),").unwrap();
let string = "1,,000.23
0,9
0.0
,55,55555,5555
";
let substitution = "$1.";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}