const regex = /web.telegram.org\/(.*) .*/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('web.telegram.org\\\/(.*) .*', 'g')
const str = `https://web.telegram.org/bb5e36a1-215a-42a5-a5b3-90a71d854bf1 vseevvev`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}