// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"web.telegram.org\/(.*) .*").unwrap();
let string = "https://web.telegram.org/bb5e36a1-215a-42a5-a5b3-90a71d854bf1 vseevvev";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}