import re
regex = re.compile(r"web.telegram.org\/(.*) .*")
test_str = "https://web.telegram.org/bb5e36a1-215a-42a5-a5b3-90a71d854bf1 vseevvev"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")