#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\$\$([^$]+)\$\$"
Local $sString = "$$paragraph_latex$$"
Local $sSubst = "<p class="latex">\\color{red}\1</p>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)