using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\$\$([^$]+)\$\$";
string substitution = @"<p class=""latex"">\\color{red}\1</p>";
string input = @"$$paragraph_latex$$";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}