use strict;
my $str = '$$paragraph_latex$$';
my $regex = qr/\$\$([^$]+)\$\$/p;
my $subst = '<p class="latex">\\\\color{red}\\1</p>';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";