$re = '/\$\$([^$]+)\$\$/';
$str = '$$paragraph_latex$$';
$subst = "<p class=\"latex\">\\color{red}\1</p>";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;