#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([\sa-zA-Z]+)\s\(\1,\s([a-zA-Z0-9]{3}\b)"
Local $sString = "phrase (phrase, ACR)" & @CRLF & _
"phrase (phrase)" & @CRLF & _
" phrase burger (phrase burger, ACR)" & @CRLF & _
" phrase Ham burger (phrase Ham burger, AsCR)" & @CRLF & _
" phrase (phrase)" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")