const regex = /([\sa-zA-Z]+)\s\(\1,\s([a-zA-Z0-9]{3}\b)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([\\sa-zA-Z]+)\\s\\(\\1,\\s([a-zA-Z0-9]{3}\\b)', 'gm')
const str = `phrase (phrase, ACR)
phrase (phrase)
phrase burger (phrase burger, ACR)
phrase Ham burger (phrase Ham burger, AsCR)
phrase (phrase)
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}