$re = '/([\sa-zA-Z]+)\s\(\1,\s([a-zA-Z0-9]{3}\b)/m';
$str = 'phrase (phrase, ACR)
phrase (phrase)
phrase burger (phrase burger, ACR)
phrase Ham burger (phrase Ham burger, AsCR)
phrase (phrase)
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);