using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([\sa-zA-Z]+)\s\(\1,\s([a-zA-Z0-9]{3}\b)";
string input = @"phrase (phrase, ACR)
phrase (phrase)
phrase burger (phrase burger, ACR)
phrase Ham burger (phrase Ham burger, AsCR)
phrase (phrase)
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}