#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[sS]ee, e\.g\.,(?![^()\n]*(?=\()(\(1st Cir\. \d{4}\))?[^()\n]*(?=\(|.)(\(2nd Cir\. \d{4}\))?[^()\n]*(?=\(|.)(\(3rd Cir\. \d{4}\))?[^()\n]*(?=\(|.)(\(4th Cir\. \d{4}\))?[^()\n]*(?=\(|.)(\(5th Cir\. \d{4}\))?[^()\n]*(?=\(|.)(\(D\.C\. Cir\. \d{4}\))?\.?$).*"
Local $sString = "See, e.g., Smith v. U.S. (1st Cir. 2012); U.S. v. Sara (3rd Cir. 2017)." & @CRLF & _
"See, e.g., Jefferson v. U.S. (2nd Cir. 2012); U.S. v. Coolidge (D.C. Cir. 2017)." & @CRLF & _
"See, e.g., Lincoln v. Jones (3rd Cir. 2012); U.S. v. Roosevelt (5th Cir. 2017)." & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"See, e.g., Smith v. U.S. (5th Cir. 2012); U.S. v. Sara (1st Cir. 2017)." & @CRLF & _
"See, e.g., Jefferson v. U.S. (D.C. Cir. 2012); U.S. v. Coolidge (10th Cir. 2017)." & @CRLF & _
"See, e.g., Lincoln v. Jones (9th Cir. 2012); U.S. v. Roosevelt (3d Cir. 2017)."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")