import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[sS]ee, e\\.g\\.,(?![^()\\n]*(?=\\()(\\(1st Cir\\. \\d{4}\\))?[^()\\n]*(?=\\(|.)(\\(2nd Cir\\. \\d{4}\\))?[^()\\n]*(?=\\(|.)(\\(3rd Cir\\. \\d{4}\\))?[^()\\n]*(?=\\(|.)(\\(4th Cir\\. \\d{4}\\))?[^()\\n]*(?=\\(|.)(\\(5th Cir\\. \\d{4}\\))?[^()\\n]*(?=\\(|.)(\\(D\\.C\\. Cir\\. \\d{4}\\))?\\.?$).*";
final String string = "See, e.g., Smith v. U.S. (1st Cir. 2012); U.S. v. Sara (3rd Cir. 2017).\n"
+ "See, e.g., Jefferson v. U.S. (2nd Cir. 2012); U.S. v. Coolidge (D.C. Cir. 2017).\n"
+ "See, e.g., Lincoln v. Jones (3rd Cir. 2012); U.S. v. Roosevelt (5th Cir. 2017).\n\n\n"
+ "See, e.g., Smith v. U.S. (5th Cir. 2012); U.S. v. Sara (1st Cir. 2017).\n"
+ "See, e.g., Jefferson v. U.S. (D.C. Cir. 2012); U.S. v. Coolidge (10th Cir. 2017).\n"
+ "See, e.g., Lincoln v. Jones (9th Cir. 2012); U.S. v. Roosevelt (3d Cir. 2017).";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}