using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[sS]ee, e\.g\.,(?![^()\n]*(?=\()(\(1st Cir\. \d{4}\))?[^()\n]*(?=\(|.)(\(2nd Cir\. \d{4}\))?[^()\n]*(?=\(|.)(\(3rd Cir\. \d{4}\))?[^()\n]*(?=\(|.)(\(4th Cir\. \d{4}\))?[^()\n]*(?=\(|.)(\(5th Cir\. \d{4}\))?[^()\n]*(?=\(|.)(\(D\.C\. Cir\. \d{4}\))?\.?$).*";
string input = @"See, e.g., Smith v. U.S. (1st Cir. 2012); U.S. v. Sara (3rd Cir. 2017).
See, e.g., Jefferson v. U.S. (2nd Cir. 2012); U.S. v. Coolidge (D.C. Cir. 2017).
See, e.g., Lincoln v. Jones (3rd Cir. 2012); U.S. v. Roosevelt (5th Cir. 2017).
See, e.g., Smith v. U.S. (5th Cir. 2012); U.S. v. Sara (1st Cir. 2017).
See, e.g., Jefferson v. U.S. (D.C. Cir. 2012); U.S. v. Coolidge (10th Cir. 2017).
See, e.g., Lincoln v. Jones (9th Cir. 2012); U.S. v. Roosevelt (3d Cir. 2017).";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}