import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "plafonders$";
final String string = "+---------+-----------------+\n"
+ "| id_word | word |\n"
+ "+---------+-----------------+\n"
+ "| 177041 | utvälj |\n"
+ "| 119270 | fonders |\n"
+ "| 39968 | flamländarens |\n"
+ "| 63567 | hänvisningarnas |\n"
+ "| 61244 | hovdansers |\n"
+ "+---------+-----------------+";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}