import re
regex = re.compile(r"plafonders$")
test_str = ("+---------+-----------------+\n"
"| id_word | word |\n"
"+---------+-----------------+\n"
"| 177041 | utvälj |\n"
"| 119270 | fonders |\n"
"| 39968 | flamländarens |\n"
"| 63567 | hänvisningarnas |\n"
"| 61244 | hovdansers |\n"
"+---------+-----------------+")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")