package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`((http(s)?:\/\/)?(www\.)?youtube\.com\/@.*)|((http(s)?:\/\/)?(www\.)?twitch\.tv\/.*)`)
var str = `https://www.youtube.com/@mallusrgreat
http://www.youtube.com/@mallusrgreat
http://youtube.com/@mallusrgreat
https://youtube.com/@mallusrgreat
https://www.youtube.com/@mallusrgreat/
http://www.youtube.com/@mallusrgreat/
http://youtube.com/@mallusrgreat/
https://youtube.com/@mallusrgreat/
asdsadhttp://youtube.com/@mall
https://www.twitch.tv/aus24
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}