import re
regex = re.compile(r"((http(s)?:\/\/)?(www\.)?youtube\.com\/@.*)|((http(s)?:\/\/)?(www\.)?twitch\.tv\/.*)")
test_str = ("https://www.youtube.com/@mallusrgreat\n"
"http://www.youtube.com/@mallusrgreat\n"
"http://youtube.com/@mallusrgreat\n"
"https://youtube.com/@mallusrgreat\n"
"https://www.youtube.com/@mallusrgreat/\n"
"http://www.youtube.com/@mallusrgreat/\n"
"http://youtube.com/@mallusrgreat/\n"
"https://youtube.com/@mallusrgreat/\n"
"asdsadhttp://youtube.com/@mall\n"
"https://www.twitch.tv/aus24\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")