import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((http(s)?:\\/\\/)?(www\\.)?youtube\\.com\\/@.*)|((http(s)?:\\/\\/)?(www\\.)?twitch\\.tv\\/.*)";
final String string = "https://www.youtube.com/@mallusrgreat\n"
+ "http://www.youtube.com/@mallusrgreat\n"
+ "http://youtube.com/@mallusrgreat\n"
+ "https://youtube.com/@mallusrgreat\n"
+ "https://www.youtube.com/@mallusrgreat/\n"
+ "http://www.youtube.com/@mallusrgreat/\n"
+ "http://youtube.com/@mallusrgreat/\n"
+ "https://youtube.com/@mallusrgreat/\n"
+ "asdsadhttp://youtube.com/@mall\n"
+ "https://www.twitch.tv/aus24\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}