#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(\(([^)]+)\))?[[:punct:]]?\p{Lu}+(?:[\s'-]?[\p{L}\d]+)+(\(([^)]+)\))*$"
Local $sString = "Éast-Shipping-ltd" & @CRLF & _
"" & @CRLF & _
"Éast-Shipping'foo(LTD)" & @CRLF & _
"" & @CRLF & _
"(LTD)$East-Shopping-Limited(LTD)" & @CRLF & _
"" & @CRLF & _
"Éast-123Shipping(LTD)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")