package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\(([^)]+)\))?[[:punct:]]?\p{Lu}+(?:[\s'-]?[\p{L}\d]+)+(\(([^)]+)\))*$`)
var str = `Éast-Shipping-ltd
Éast-Shipping'foo(LTD)
(LTD)$East-Shopping-Limited(LTD)
Éast-123Shipping(LTD)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}