$re = '/^(\(([^)]+)\))?[[:punct:]]?\p{Lu}+(?:[\s\'-]?[\p{L}\d]+)+(\(([^)]+)\))*$/m';
$str = 'Éast-Shipping-ltd
Éast-Shipping\'foo(LTD)
(LTD)$East-Shopping-Limited(LTD)
Éast-123Shipping(LTD)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);