re = /^(\(([^)]+)\))?[[:punct:]]?\p{Lu}+(?:[\s'-]?[\p{L}\d]+)+(\(([^)]+)\))*$/m
str = 'Éast-Shipping-ltd
Éast-Shipping\'foo(LTD)
(LTD)$East-Shopping-Limited(LTD)
Éast-123Shipping(LTD)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end