#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)((?=\S*?[A-Z])(?=\S*?[^\w\s])(?=\S*?[a-z])(?=\S*?[0-9]).{8,})\S"
Local $sString = "This@154p455word" & @CRLF & _
"" & @CRLF & _
"notapaSsw0rd"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")