import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?=\\S*?[A-Z])(?=\\S*?[^\\w\\s])(?=\\S*?[a-z])(?=\\S*?[0-9]).{8,})\\S";
final String string = "This@154p455word\n\n"
+ "notapaSsw0rd";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}