import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:<select\\b|\\G).*?(\\b\\d{4}(?:\\s*\\d{4}){3}\\b)(?=.*?</select>)";
final String string = "blah 1234 1234 4567 5678 blah\n"
+ "<select id=\"test:j_id_ca\" name=\"test:j_id_ca\" class=\"x2h\" style=\"font-weight:bold;\"><option value=\"0\" selected>1111 1111 1111 1111</option><option value=\"0\" selected>2222 2222 2222 2222</option></select>\n\n"
+ "blah 1234 1234 4567 5678 blah\n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}