import re
regex = re.compile(r"(?:<select\b|\G).*?(\b\d{4}(?:\s*\d{4}){3}\b)(?=.*?</select>)")
test_str = ("blah 1234 1234 4567 5678 blah\n"
"<select id=\"test:j_id_ca\" name=\"test:j_id_ca\" class=\"x2h\" style=\"font-weight:bold;\"><option value=\"0\" selected>1111 1111 1111 1111</option><option value=\"0\" selected>2222 2222 2222 2222</option></select>\n\n"
"blah 1234 1234 4567 5678 blah\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")