$re = '~(?:<select\b|\G).*?(\b\d{4}(?:\s*\d{4}){3}\b)(?=.*?</select>)~';
$str = 'blah 1234 1234 4567 5678 blah
<select id="test:j_id_ca" name="test:j_id_ca" class="x2h" style="font-weight:bold;"><option value="0" selected>1111 1111 1111 1111</option><option value="0" selected>2222 2222 2222 2222</option></select>
blah 1234 1234 4567 5678 blah
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);