using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=,)([\w\s]*Red\sKidney[\w\s]*)(?=,)";
string input = @"Includes a minimum of 8 (But could include nearly all) of the following, both whole and split: Adzuki Beans, Baby Lima Beans, Black Beans, Blackeye Peas, Cranberry Beans, Dark Red Kidney Beans, Garbanzos, Great Northern Bean, Large Lima beans, Light Red Kidney Beans, Navy Beans, Pink Beans, Navy Beans, Small Red Beans, White Kidney Beans, Yellow Beans, Green and Yellow Split Peas, Lentils";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}