use strict;
my $str = 'Includes a minimum of 8 (But could include nearly all) of the following, both whole and split: Adzuki Beans, Baby Lima Beans, Black Beans, Blackeye Peas, Cranberry Beans, Dark Red Kidney Beans, Garbanzos, Great Northern Bean, Large Lima beans, Light Red Kidney Beans, Navy Beans, Pink Beans, Navy Beans, Small Red Beans, White Kidney Beans, Yellow Beans, Green and Yellow Split Peas, Lentils';
my $regex = qr/(?<=,)([\w\s]*Red\sKidney[\w\s]*)(?=,)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}