import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=,)([\\w\\s]*Red\\sKidney[\\w\\s]*)(?=,)";
final String string = "Includes a minimum of 8 (But could include nearly all) of the following, both whole and split: Adzuki Beans, Baby Lima Beans, Black Beans, Blackeye Peas, Cranberry Beans, Dark Red Kidney Beans, Garbanzos, Great Northern Bean, Large Lima beans, Light Red Kidney Beans, Navy Beans, Pink Beans, Navy Beans, Small Red Beans, White Kidney Beans, Yellow Beans, Green and Yellow Split Peas, Lentils";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}