$re = '/(?<=,)([\w\s]*Red\sKidney[\w\s]*)(?=,)/m';
$str = 'Includes a minimum of 8 (But could include nearly all) of the following, both whole and split: Adzuki Beans, Baby Lima Beans, Black Beans, Blackeye Peas, Cranberry Beans, Dark Red Kidney Beans, Garbanzos, Great Northern Bean, Large Lima beans, Light Red Kidney Beans, Navy Beans, Pink Beans, Navy Beans, Small Red Beans, White Kidney Beans, Yellow Beans, Green and Yellow Split Peas, Lentils';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);