using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^[A-Z0-9\&\'s\-\040]{2,})\040";
string input = @"PANTENE Pro-v acondicionador aqua light cabello fino bote 300 ml
GALLINA BLANCA sopa
COCA-COLA Orxata de la terreta
M&M's saco cacahuete bolsa 220 gr
MAHOU 5 ESTRELLAS Cervesa
CVNE CARO Vino tinto reserva DO Rioja botella 75 cl""
MARCA BLANCA bombones
COCA COLA Clásica botella 1.5 lt""";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}