re = /(^[A-Z0-9\&\'s\-\040]{2,})\040/
str = 'PANTENE Pro-v acondicionador aqua light cabello fino bote 300 ml
GALLINA BLANCA sopa
COCA-COLA Orxata de la terreta
M&M\'s saco cacahuete bolsa 220 gr
MAHOU 5 ESTRELLAS Cervesa
CVNE CARO Vino tinto reserva DO Rioja botella 75 cl"
MARCA BLANCA bombones
COCA COLA Clásica botella 1.5 lt"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end