use strict;
my $str = 'PANTENE Pro-v acondicionador aqua light cabello fino bote 300 ml
GALLINA BLANCA sopa
COCA-COLA Orxata de la terreta
M&M\'s saco cacahuete bolsa 220 gr
MAHOU 5 ESTRELLAS Cervesa
CVNE CARO Vino tinto reserva DO Rioja botella 75 cl"
MARCA BLANCA bombones
COCA COLA Clásica botella 1.5 lt"';
my $regex = qr/(^[A-Z0-9\&\'s\-\040]{2,})\040/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}