// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(^[A-Z0-9\&\'s\-\040]{2,})\040").unwrap();
let string = "PANTENE Pro-v acondicionador aqua light cabello fino bote 300 ml
GALLINA BLANCA sopa
COCA-COLA Orxata de la terreta
M&M's saco cacahuete bolsa 220 gr
MAHOU 5 ESTRELLAS Cervesa
CVNE CARO Vino tinto reserva DO Rioja botella 75 cl\"
MARCA BLANCA bombones
COCA COLA Clásica botella 1.5 lt\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}