using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Mr\.?\s*([A-Z](?:[^\s:]|\s(?=[A-Z]))+)(?=[\s]*[(:])[^:]*:\s*(.+)";
string input = @"Mr. Paul (speaks in English): Blablablabloo.
Mr. Hernandez Gabriel Theodor (speaks in Spanish): Wibble.
Mr. Jenchewkow (speaks in Russian, translation provided): Hello all! Happy days!
Mr. Puk once said: ‚Hello‘ and I want to second that.
Mr. Peter thought it acceptable that: Peter Piper picked a peck.
Mr Paul: Hello!
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}