import Foundation
let pattern = #"Mr\.?\s*([A-Z](?:[^\s:]|\s(?=[A-Z]))+)(?=[\s]*[(:])[^:]*:\s*(.+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Mr. Paul (speaks in English): Blablablabloo.
Mr. Hernandez Gabriel Theodor (speaks in Spanish): Wibble.
Mr. Jenchewkow (speaks in Russian, translation provided): Hello all! Happy days!
Mr. Puk once said: ‚Hello‘ and I want to second that.
Mr. Peter thought it acceptable that: Peter Piper picked a peck.
Mr Paul: Hello!
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)