const regex = /Mr\.?\s*([A-Z](?:[^\s:]|\s(?=[A-Z]))+)(?=[\s]*[(:])[^:]*:\s*(.+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Mr\\.?\\s*([A-Z](?:[^\\s:]|\\s(?=[A-Z]))+)(?=[\\s]*[(:])[^:]*:\\s*(.+)', 'gm')
const str = `Mr. Paul (speaks in English): Blablablabloo.
Mr. Hernandez Gabriel Theodor (speaks in Spanish): Wibble.
Mr. Jenchewkow (speaks in Russian, translation provided): Hello all! Happy days!
Mr. Puk once said: ‚Hello‘ and I want to second that.
Mr. Peter thought it acceptable that: Peter Piper picked a peck.
Mr Paul: Hello!
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}