import re
regex = re.compile(r"Mr\.?\s*([A-Z](?:[^\s:]|\s(?=[A-Z]))+)(?=[\s]*[(:])[^:]*:\s*(.+)", flags=re.MULTILINE)
test_str = ("Mr. Paul (speaks in English): Blablablabloo.\n"
"Mr. Hernandez Gabriel Theodor (speaks in Spanish): Wibble.\n"
"Mr. Jenchewkow (speaks in Russian, translation provided): Hello all! Happy days!\n"
"Mr. Puk once said: ‚Hello‘ and I want to second that.\n"
"Mr. Peter thought it acceptable that: Peter Piper picked a peck.\n"
"Mr Paul: Hello!\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")