#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(href=")([^"]*\.[^".]+)(")"
Local $sString = "<li><a href="Blah/Index.html">Blah</a></li>" & @CRLF & _
"<li><a href="/blah/Index.html">Blah</a></li>" & @CRLF & _
"<li><a href="../Blah/index.html">Blah</a></li>" & @CRLF & _
"<li><a href="../Foo/Index.html">Foo</a></li>"
Local $sSubst = "$1\L$2\E$3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)