$re = '~(href=")([^"]*\.[^".]+)(")~m';
$str = '<li><a href="Blah/Index.html">Blah</a></li>
<li><a href="/blah/Index.html">Blah</a></li>
<li><a href="../Blah/index.html">Blah</a></li>
<li><a href="../Foo/Index.html">Foo</a></li>';
$subst = "$1\L$2\E$3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;