use strict;
my $str = '<li><a href="Blah/Index.html">Blah</a></li>
<li><a href="/blah/Index.html">Blah</a></li>
<li><a href="../Blah/index.html">Blah</a></li>
<li><a href="../Foo/Index.html">Foo</a></li>';
my $regex = qr~(href=")([^"]*\.[^".]+)(")~mp;
my $subst = '$1\\L$2\\E$3';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";