using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=[^a-z\n]*[a-z])(?=[^A-Z\n]*[A-Z])(?=[^0-9\n]*[0-9])[a-zA-Z0-9]{6,}$";
string input = @"ghdfj32
DSJKHD23
13445543
RFERTETT
fgrthrthr
dfEFGR45
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}