$re = '/^(?=[^a-z\n]*[a-z])(?=[^A-Z\n]*[A-Z])(?=[^0-9\n]*[0-9])[a-zA-Z0-9]{6,}$/m';
$str = 'ghdfj32
DSJKHD23
13445543
RFERTETT
fgrthrthr
dfEFGR45
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);