re = /^(?=[^a-z\n]*[a-z])(?=[^A-Z\n]*[A-Z])(?=[^0-9\n]*[0-9])[a-zA-Z0-9]{6,}$/m
str = 'ghdfj32
DSJKHD23
13445543
RFERTETT
fgrthrthr
dfEFGR45
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end