import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=[^a-z\\n]*[a-z])(?=[^A-Z\\n]*[A-Z])(?=[^0-9\\n]*[0-9])[a-zA-Z0-9]{6,}$";
final String string = "ghdfj32\n"
+ "DSJKHD23\n"
+ "13445543\n"
+ "RFERTETT\n"
+ "fgrthrthr\n\n"
+ "dfEFGR45\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}