use strict;
my $str = 'VALID EMAILS:
davida@yahoo.com, davida-100@yahoo.com, davida.100@yahoo.com, davida111@davida.com, davida-100@davida.net, davida.100@davida.com.au, davida@1.com, davida@gmail.com.com, davida+100@gmail.com, davida-100@yahoo-test.com valid special char ~@davidalberto.com hey@ucl.ac.uk, "this..one"@gmail.com, h.e.y@gmail.com,
the "." at the start should be ignored .davida@davida.com,
suffix should be ignored davida@gmail.com.1a
prefix should be ignored davida@davida@gmail.com,
INVALID EMAILS:
davida, davida@.com.my, davida123.@gmail.a, davida123@gmail.a, davida123@.com, davida123@.com.com, davida()*@gmail.com, davida@%*.com, davida.@gmail.com,
tld is too long davida@gmail.comnnnnnnnn
INVALID EMAILS - TODO:
adjacent "." should not be valid davida..2002@gmail.com
some images a@bg.png 1x@cover.gif
HIDDEN EMAILS:
somethingatgmail.com
something at gmail.com something AT gmail.com
asdf ( at ) gmail.com yoooo (at) gmail.com
HIDDEN EMAILS - TODO:
this at that dot com
this [at] that [dot] com
-----
';
my $regex = qr/(?:\.?)([\w\-_+#~!$&\'\.]+(?<!\.)@(?<!\.)[\w]+[\w\-\.]*\.[a-zA-Z-]{2,3})(?:[^\w])/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}